[MidoNet-user] Error during Midonet installation

Vijay Srinivasan Vijay.Srinivasan at netmagicsolutions.com
Thu Nov 20 08:28:18 UTC 2014


Hi,

I am evaluating the Midonet controller for my environment. I want to build my network with VxLAN overlays.
I  want to use Midonet to provision VNI’s in the VTEP’s. I am starting with Openvswitch as of now.

While installing the Midonet as per the instruction given in the website - http://www.midonet.org/, I got the below error.  I tried repeatedly and I got the same error.
Request your assistance on what should I do next?

OS and Kernel version –
vagrant at vagrant-ubuntu-trusty-64:~/midostack$ uname -a
Linux vagrant-ubuntu-trusty-64 3.13.0-39-generic #66-Ubuntu SMP Tue Oct 28 13:30:27 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

midostack/logs/2014-11-20-115241/midonet/midonet_stack.sh.stderr.log
+ LOGFILE=/home/vagrant/midostack/logs/2014-11-20-115241/midonet/020.setup_fake_uplink.sh.log
+ . /home/vagrant/midostack/scripts/post_devstack.d/020.setup_fake_uplink.sh
+ echo /home/vagrant/midostack/scripts/post_devstack.d/020.setup_fake_uplink.sh ' [FAILED]'
+ echo 'Exiting midostack. Check out the log (also stored in /home/vagrant/midostack/logs/2014-11-20-115241/midonet/020.setup_fake_uplink.sh.log):'
+ echo '========== LOG:'
+ cat /home/vagrant/midostack/logs/2014-11-20-115241/midonet/020.setup_fake_uplink.sh.log
+ echo '=== End of LOG ==='
+ echo Exiting...
+ exit 1

/home/vagrant/midostack/logs/2014-11-20-115241/midonet/020.setup_fake_uplink.sh.log
++ sudo ip link add type veth
++ sudo ip link set dev veth0 up
++ sudo ip link set dev veth1 up
++ sudo brctl addbr uplinkbridge
++ sudo brctl addif uplinkbridge veth0
++ sudo ip addr add 172.19.0.1/30 dev uplinkbridge
++ sudo ip link set dev uplinkbridge up
++ sudo sysctl -w net.ipv4.ip_forward=1
net.ipv4.ip_forward = 1
++ sudo ip route add 200.200.200.0/24 via 172.19.0.2
++ /home/vagrant/midostack/scripts/setup_fake_uplink.sh -a http://10.0.2.15:8081/midonet-api -u admin -p gogomid0 -i admin -c /opt/stack/midonet/python-midonetclient
Found Provider Router with ID cf56760c-65d6-4575-b504-a99c72af9c58
Found Provider Router Port with ID b43a8df4-9875-4869-a47d-b8faea04ea49
Created Route on provider router with ID 138fcfd6-7a8a-454b-9109-91bb2457e937
Created a new tunnel zone with ID a10b734a-2123-4a55-b335-452a2e088427 and name       default_tz
Found host with id c4875f63-af2d-4252-bfdc-38dd2d6c72df
Added member zone a10b734a-2123-4a55-b335-452a2e088427 host c4875f63-af2d-4252-bfdc-38dd2d6c72df address 172.19.0.2 to the tunnel zone
Added binding host c4875f63-af2d-4252-bfdc-38dd2d6c72df interface veth1 port b43a8df4-9875-4869-a47d-b8faea04ea49
++ /home/vagrant/midostack/scripts/verify_fake_uplink.sh -a http://10.0.2.15:8081/midonet-api -u admin -p gogomid0 -i admin -c /opt/stack/midonet/python-midonetclient
Found Provider Router with ID cf56760c-65d6-4575-b504-a99c72af9c58
FAILED to ping the provider router

Thanks and Regards.

~ Vijay
Vijay Srinivasan
Associate Vice President - IT Engineering
IT Engineering
Netmagic (An NTT Communications Company)
Direct:  +91-22-40411799 | Cell:  +91-9987745360
Email: vijay.srinivasan at netmagicsolutions.com   [http://www.netmagicsolutions.com/assets/images/EDM/others/branding_guide/15-year-logo5.jpg]

Linkedin<http://www.linkedin.com/company/netmagic?trk=fc_badge> | Twitter<http://twitter.com/netmagic> | Youtube<http://www.youtube.com/user/netmagicsolutions> | Blog<http://www.netmagicsolutions.com/blog> | News<http://www.netmagicsolutions.com/news> | Whitepapers<http://www.netmagicsolutions.com/resources/whitepapers/> | Case Studies<http://www.netmagicsolutions.com/resources/case-studies/>



________________________________
This e-mail message, including any attachments, is for the sole use of the individual or entity to whom it has been addressed, and may contain information that is confidential or legally protected. If you are not the intended recipient(s) or have received this message in error, you are not authorized to copy, distribute, or otherwise use this message or its attachments. Please notify the sender immediately by return e-mail and permanently delete this message and any attachments. The contents of this message do not necessarily represent the views or policies of Netmagic Solutions Private Limited or its affiliates / group companies (“Netmagic”). Netmagic makes no warranty that this e-mail is error or virus free.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.midonet.org/pipermail/midonet-user/attachments/20141120/1d8e09c4/attachment.html>


More information about the MidoNet-user mailing list